
Self-Publishing with Scrivener

Ebook Devices and Formats

Seller Device File Name
Amazon Kindle .mobi, .azw
Amazon Kindle Fire .KF8(.azw3).mobi
Barnes & Noble Nook ePub
Adobe Adobe Digital Ed. ePub
Rakuten Kobo ePub

Apple iBooks (iPad, iPhone)
.ibooks, ePub



Tools You Need to Self-Publish with Scrivener

Kindle

1. KindleGen tool 
This free downloaded software converts your file to a .mobi or KF8 format. The 

software is available for Mac or PC. Scrivener has a direct link to download this 
(click File>Compile), or go to www.amazon.com/kindlepublishing.

2. Kindle Previewer (Kindle Previewer2)
This free downloaded software lets you see how your new ebook file will look on 

a Kindle device or app. http://www.amazon.com/gp/feature.html?
ie=UTF8&docId=1000234621 You can also load your file onto your Kindle.

http://www.amazon.com/kindlepublishing
http://www.amazon.com/gp/feature.html?ie=UTF8&docId=1000234621
http://www.amazon.com/gp/feature.html?ie=UTF8&docId=1000234621
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EPub

1. EPub Validator
Validates the file to make sure it fits the ePub standard. http://validator.idpf.org/

2. Adobe Digital Editions

Like Kindle Previewer, this lets you see how your book will look. http://
www.adobe.com/products/digital-editions.html You can also install your book on an 
ereader or iPad.

http://validator.idpf.org/
http://www.adobe.com/products/digital-editions.html
http://www.adobe.com/products/digital-editions.html


Set Up Your Ebook

1. Template
You will want to use the 'novel' template (under 'fiction'), as this format 

already contains formatted 'front matter', and saves you lots of time creating 
your own. 

If you look in the binder, you'll see that you  already have spots for:
• your cover
• title page
• Copyright
• dedication 
• Acknowledgements
Other templates may not have these set up, making your task more 

difficult. This method will make compiling very easy.
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You can also add:
• an 'other books by' page
• a blurb page
• a 'sneak peek' at the next book
• an author page, where you place a short bio and point to your website 

and social media links. 

The 'novel' template is the easiset way to add these items. If your 
Scrivener file is not in the 'novel' format template, just open a new Scrivener 
file. Choose Fiction>Novel. When Scrivener asks you to name your project, 
use your book's title as the name. Then open your current Scrivener file that 
contains your manuscript. Overlap these two files so that you can see the 
new Binder just to the left of your project's Binder. Drag and drop each 
document that will be in your book over to the new Scrivener file.
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2. Set up front matter
Click the arrow next to 'front matter' so the arrow points down. Choose 

'paperback novel' (I know there's a section marked 'e-book'. We'll get 
there!)

You'll see three folders here:
• Manuscript Format Folder: this will be used if you are sending a 

hard copy of your manuscript to an agent or editor. We will skip this.
• Paperback Novel Folder: this folder contains the Title Page, 

Copyright page, Dedication, and Blank Page.
Choose 'Title Page'. You will see what looks like HTML code. These are 

placeholders for meta data. Don't worry if you don't know HTML!
Choose Project>Meta-Data Settings>Project Properties. Fill out your 

title and author name. Click 'ok'. These tags get replaced with the 
information you filled in. You can edit those settings or just replace this text 
altogether.
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Choose 'Copyright Page'. The copyright page has a place for your 
ISBN numbers, and for legal disclaimers, if needed.

Choose 'Dedication'. If you don't want this page, highlight it in the 
binder and click the red 'trash' button.

 If you would like to add more pages, click the green 'Add' button. Some 
authors add a foreword, or blurbs about their book.

Note the 'blank page' document. This has a placeholder tag. This tag 
tells Scrivener that this page is intentionally left blank (the tag will not show 
up in your book). Without this, Scrivener will automatically delete the page. 
Flip through other books to see where you might want to use a blank page. 
If you need more than one blank page, just click the green + button and 
copy and paste the placeholder tag, or choose 
Documents>Duplicate>without Subdocuments.
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• Ebook Folder: This third folder has a sample cover and dedication 
page. You can copy and paste your dedication from the Paperback 
Folder. Since we'll need a title page and copyright page for our ebook, 
we will select those two files in the Paperback Folder, then go to 
Documents>Duplicate>without Subdocuments. This will create an 
exact copy. All you need to do is drag the document to the ebook 
folder. If you would like to add pages, like a foreword, 
acknowledgements, a list of your other books, or endorsements, 
highlight 'ebook' and click the green 'add' button, and then type into 
those documents. 

3. Back matter
If you would like to add pages, like 'about the author', or a teaser chapter 

for a forthcoming book, add a new document for each one after the last 
chapter of your manuscript. Do this by highlighting the last chapter of 
your manuscript and clicking the green 'add' button. Type the name of the 
file, then add your content.
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4. Upload your cover
Make sure your cover fits the recommended dimensions for the platform 

you will export to. Drag and drop your cover image next to the 'cover' file in 
the ebook folder in the Binder. You can then put Scrivener's stock cover in 
the trash.

If you're creating your own cover, or hiring a graphic artist, this post 
keeps the  dimensions updated (they may differ from the table 
below):

http://ebookindiecovers.com/ebook-cover-size-

requirementsspecifications/

http://ebookindiecovers.com/ebook-cover-size-requirementsspecifications/
http://ebookindiecovers.com/ebook-cover-size-requirementsspecifications/
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Platform Pixels File Format

Kindle 625X1000 min 

Recommended:

1563X2500

.jpg or TIFF

Nook
H&W between 

750-1400
.jpg or .png

Smashwords 500X800 .jpg

Kobo 900dpi (less than 1MB) .jpg or .png



The Compile Process: Kindle (.mobi) 

While there may seem to be many steps, if you were to do this for each 
ebook format, you'd spend weeks of time. Just read through the format 
books for the different platforms! Scrivener simplifies things. First, we'll put 
a manuscript into Kindle format. Then we can make some simple 
adjustments for other ebook formats. 

Note: the main instructions are for a Mac computer. If the instructions 
differ for a PC, they are in brackets.

*Make sure you've downloaded KindleGen already.*
[For PC, select 'Manuscript' in the Binder first]

1. Click File>Compile (or Compile button)
[For PC: if Compile box has only two white rectangles, click the down arrow to enlarge.]

a. At the top of the box, click 'Format as'>ebook (the default will probably 
be 'novel'). You'll notice the lefthand list of 'Compilation Options' will change 
slightly.

b. At the bottom of the box, click 'Compile for'> Kindle ebook. An option 
to download KindleGen will pop up. If you've downloaded it, you'll be able to 
install it now. You'll notice KindleGen will show up in the list of items on the 
left under 'Compilation Options'. (If you don't see 'Compilation Options', you 
may be in 'Summary' mode. Look at the top of the box and click 'All 
Options'.)

c. Under 'Format as Ebook', make sure the next drop-down menu has 
'Manuscript' selected. The list below 'Manuscript' should match the items 
under 'Manuscript' in your binder. If something is missing, make sure that 
item falls under the manuscript folder (don't worry about front matter and 
cover at this point).

Note: we could publish our ebook from Scrivener's template. However, it is handy in 
the long run to create a custom template, which will not override the Scrivener 
template. Don't worry, it's not hard.

d. Click 'Compile for' again. Scroll to the bottom, and select 'Manage 
Compile Format Presets'. Click the '+' sign, and when a box pops up, give it 
the name of your book, followed by 'Kindle'. Though this seems strange, 
when you want to export to other formats, it will save you lots of time. Now 
click 'ok'.

e. Again, at the top of the Compile box, click 'Format as'>{name of your 
book}. Now, any changes we make will affect only this preset, and not 
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Scrivener's ebook preset.
2. Click 'Contents' on the left

In the center, you'll see your list of documents.  
3. Click 'Include' and add Front Matter

Check the box for each document you want to include. Don't worry about 
the column marked 'page break before'. We'll deal with page breaks in part 
four. The 'as-is' column determines whether Scrivener keeps the exact 
formatting you used for each document or not. Generally, you want to check 
the 'as-is' box for your front matter, but not for your chapters. Near the 
bottom of the compile box, click 'add front matter' and navigate the drop-
down menu to the E-book folder.

4. Click 'Separators'
Make sure 'section break' is selected in the drop down menu for all four 

parts. This is what places your page breaks, for example, each chapter will 
begin on a new page.
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5. Click 'Cover'
Click 'no cover image', and select the cover you dragged in earlier from 

the drop-down menu. The image should show up in the box.

6. Update your preset.
Since we've made changes to our custom preset for this book, we need 

to save those changes occasionally. If I were to leave Compile to make 
changes to my manuscript without saving, I'd have to go back through all 
the steps we've done already. To save the changes so far, go to Format 
as:>Manage Compile Format Presets>{your book title}. Then click 'Update'. 
A dialogue box will pop up to ask you if you want to override what you've 
done so far. Click 'yes', then 'ok'. Do this occasionally when you've made 
changes to your preset. [PC: click 'save preset' button on left. Next time you 
need that preset, click 'load preset'.]
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7. Click 'Formatting'
This is where you have a lot of freedom to get fancy with your ebook. 

I'll give you the simplest ways to set things up for now--I don't want to 
overwhelm you!

The bottom half shows an example of what your pages will look like. 
The top half shows your documents with some different options. Uncheck the 
first box under 'Title'.

8. 'Layout'
Click 'Generate HTML Table of Contents', if you want your chapters to be 
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clickable for readers. Click 'center', if you want it centered.

9. Click 'Transformations'
If you're worried that you might have hit the space bar twice after 

sentences, click 'remove trailing white space from documents' and 'convert 
multiple spaces to single space'. There are some other options here that you 
can explore if you'd like.
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10. HTML Settings
If you'd like any web links to be 'live' in your ebook, click 'convert 

Scrivener links to HTML links'.

11. Replacements
This can be used if you want to make changes to your whole document. 

Say you needed to change the name of a character. This is the place to do it. 
This is seldom used.

12. Statistics/Tables/Footnotes & Comments
We don't have time to go into these, but they are used more for non-

fiction and research papers.

13. Click 'Meta-Data'
You filled most of this out before, but you can add to it here. If you have 

an ISBN, click 'use custom unique identifier', and enter the ISBN in the box.

14. Save your preferences
Go back to 'Manage Compile Format Presets'. Click the word 'update'. Say 

'ok' to override, and 'ok' to save. Now we're ready to compile!

15. Click 'Compile' at the bottom
Save the document with the file name and location of your choice. It will 

get exported as your chosen file.

16. Open Kindle Previewer
Choose 'Open Book'. Select your file, click 'open'. You can now look at it 

in different Kindle formats. Click on the cover icon to see your cover. Click 
the Table of Contents and check to see if your chapters are clickable. Use the 
arrows to navigate back and forth.

You did it!
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The Compile Process: .Epub
Now that you have the Kindle format ready, it's super easy to format in 

ePub. This file allows you to publish on Nook, iBooks, and Kobo.
[For PC, select 'Manuscript' in the Binder first]

1. Click File>Compile
Click 'Format As'. Scroll to the bottom, and select 'Manage Compile 

Format Presets'. Click the '+' sign, and when a box pops up, give it the name 
of your book, followed by 'Epub'. Make sure your 'Compile for' has this 
selected (your book name, with Epub).

At the bottom of the box, click 'Compile for'>Epub ebook.

2. Click 'Contents'
At the bottom of the box, click 'add front matter'. To the right, select 

'ebook'.

3. Click 'Compile' at the bottom
Save the document with the file name and location of your choice. It will 

get exported as your chosen file. That's all there is!

4. To view your book online:
1. Go to www.magicscroll.net
2. Click 'add a book to your library
3. Choose the file from your computer. Select it and choose 'open'.
4. The book will appear on the site. Select it and navigate through the book.

http://www.magicscroll.net


Need more help?

For those who like one-on-one training, I am available for private 
Scrivener tutoring, in person, or via Skype. Email me requesting 'Scrivener 
Tutoring Info' at dallenco@gmail.com.

For instant review, I recommend the Scrivener Coach site. It is a 
membership site, but can be worthwhile if you like repetition, and want to 
check out other advanced features. Joseph Michael has a huge library of 
videos. You can try the coupon code 'selfpublishing'. If it's still active, you 
might save some. http://bit.ly/1kORYD2

Dropbox is a program you download that gives you free cloud storage. A 
folder sits on your desktop, and whatever you place inside it gets stored to 
the cloud. I keep all my Scrivener files in there. Your stored files are 
accessible from any computer. http://bit.ly/1izlUAb

Other helpful links for Kindle publishing:

Amazon Kindle Publishing Guidelines:
http://kindlegen.s3.amazonaws.com
AmazonKindlePublishingGuidelines.pdf
Formatting images in your book: 
https://kdp.amazon.com/help?topicId=A1B6GKJ79HC7AN
General Kindle publishing help: 
https://kdp.amazon.com/help
Help with creating your cover image: 
https://kdp.amazon.com/help?topicId=A2J0TRG6OPX0VM

Links for Other Platforms:

Barnes & Noble Epub Formatting Guide:
https://simg1.imagesbn.com/pimages/pubit/support/
pubit_epub_formatting_guide.pdf
Kobo Cover Requirements:
http://download.kobobooks.com/learnmore/writinglife/KWL-User
Guide.pdf
Smashwords Style Guide:
https://www.smashwords.com/books/view/52

mailto:dallenco@gmail.com
http://bit.ly/1kORYD2
http://bit.ly/1izlUAb
http://kindlegen.s3.amazonaws.com
http://kindlegen.s3.amazonaws.com/AmazonKindlePublishingGuidelines.pdf
https://kdp.amazon.com/help?topicId=A1B6GKJ79HC7AN
https://kdp.amazon.com/help
https://kdp.amazon.com/help?topicId=A2J0TRG6OPX0VM
https://simg1.imagesbn.com/pimages/pubit/support/
https://simg1.imagesbn.com/pimages/pubit/support/pubit_epub_formatting_guide.pdf
http://download.kobobooks.com/learnmore/writinglife/KWL-User
http://download.kobobooks.com/learnmore/writinglife/KWL-User-Guide.pdf
https://www.smashwords.com/books/view/52
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CreateSpace Cover Requirements:
https://www.createspace.com/Products/Book/CoverPDF.jsp

https://www.createspace.com/Products/Book/CoverPDF.jsp

